Plex 1.27.2 seems to break hw transcode

I run the plex container on a device similar to an Intel NUC. The processor is the Intel Celeron J4125. So, I am using QSV to HW transcode all of my HEVC videos. I recently updated plex to 1.27.2 and noticed that while watching one of my HEVC videos it was buffering. I took a peak and the video was not utilizing HW transcode. I had not changed anything in my setup and merely used docker-compose to manually update my container.

I started troubleshooting and downgraded plex to 1.27.0 by using the version tag instead of latest. HW transcode immediately started working. I then upgraded to 1.27.1 and it still worked. I finally upgraded to 1.27.2 after deleting all dangling images by explicitly calling it. This again broke HW transcode, so I downgraded back to 1.27.1.

I have yet to do any further testing or log collection. If that is needed, please let me know what you would like and I’ll try and find some time this weekend to get through the testing/collection.