Plex docker container is unable to traverse mapped folder with spaces

Hi everyone,

I run Plex on my Synology NAS, previously native package installation, just now migrated to plex docker container. I create my container using docker compose, mapping my shares as such:

      - '/volume2/NAS Media:/volume2/NAS Media'
      - '/volume2/NAS iTunes:/volume2/NAS iTunes'

Migration went fine, all my libraries are accessible by plex server, files can be read and played, BUT plex interface is unable to traverse or read media directories, because it displays them as “NAS\040Media”.

Here’s how it looks like from the container shell (so container system can properly see and traverse mapped directories):

Library paths inherited from native installation do work and plex reads those files perfectly well.

But adding or editing these paths is impossible because plex changes space to \040 and asks the system for this path, which does not exist (apparently, does not change \040 to space back).

I verified that it’s not a permission issue, as permissions are configured correctly, as well as it can traverse a symlink to this directory just fine as soon as there is no space in its name.

Anything I am doing wrong, or ideas how to fix that? I can rename my paths to not have spaces and it will work (I just tried to do this with NAS iTunes library), but this just sounds like a workaround for something that shouldn’t have happened in the first place.

Here’s how it looks to plex interface - this path is inherited from native installation and works (plex can read and play media in it):

But here’s what happens if I try to add this same directory to the library: