Plex in OMV Docker how to recognize tuner card

I’m running amd64 OMV with docker plex how do I recognize my win media tuner card. lshw list as present.

You need to somehow add the /dev/dvb device to the container.
I don’t know how in OMV, but the command line option is --device=/dev/dvb

OMV is using Debian Linux (Stretch) OS there is no /dev/dvb do I make a directory? I wget the wintv firmware and placed it in /lib/firmware/.

The underlying OS needs to recognize the card and load the drivers, then /dev/dvb will be available and you can pass that to the container

Thank you for your help. I followed the instruction @ is there any way of knowing if the OS can recognize the card? Lspci is showing the card.

The card will show up in the /dev/dvb folder if you installed the drivers. If it’s not there, you haven’t installed it correctly.

Thanks working on it.

I can run plex outside of the docker and the tuner card is recognized, still no luck with the docker, I added dev/dvb to the parameters. I’m not sure if I did it right I followed the same dev/dri in the right up.

It’s likely the permissions. Our image automatically fixes the permissions on /dev/dri but not /dev/dvb
For now you can chmod 777 /dev/dvb on host and restart the container

I changed the permission and check it with ls -la /dev/dvb and it shows full permission. restarted the container. still no luck. I have to stop for today I’ll continue tomorrow.
Thanks for all the help.

I’ve asked for help on the openmediavault forum, thinking this might be a problem with there OS. I’ll post updates

Hi I’d like to thank aptalca and saarg for your help. I bashed into the docker and listed the folders and found that dev was listed but not dvb. I added dvb to the volume and dev/dvb to device and still plex can’t see the wintv cards if no one has any more ideals I believe I’ll stick to installing plex directly thank you again. Greg

You do not use the volume mount for a device. You use the device tag. --device=/dev/dvb in command line. In OMV, I don’t know how it’s done.
You do have /dev/dvb on the host now?

yes host has dev/dvb and plex install on host can see the wintv cards, when I tried the --device=/dev/dvb plex could not see cards and the docker could not see /dev/dvb only /dev. I back out of the volume mount restarted the docker. The plex docker still can’t see the wintv cards. Is there away to check why?

saarg new update I believe I added device=/dev/dvb:/dev/dvb to the plex container since after I docker exec -it Plex2 bash I can ls -la /dev/dvb, the results are drwxr-xr-w for the folder and crw-r-w---- for the files. The plex app in the container still won’t recognize the wintv cards!!! Do you still think it’s a permission issue?

Hi I used docker inspect the results for device was “” “Devices”: [
“PathOnHost”: “/dev/dvb”,
“PathInContainer”: “/dev/dvb”,
“CgroupPermissions”: “rwm”
Looks like the container has access to the wintv cards.

On the host, try doing a chmod -R 777 /dev/dvb That should make permissions wide open for it.

Also, there are reports of the latest plex version not recognizing dvb cards, but downgrading to the previous version makes it work. There are some forum posts on plex about it, like this one:

Thanks aptalca the chmod -R 777 /dev/dvb worked!!! Problem solved wintv tuner cards working great!! thank you as well saarg I had given up but your reply spurred me on to keep trying.
Thank you everyone.

Glad to hear. We’ll get the permissions figured out in the image so you won’t have to chmod in the future

Update I power down my PC to add a harddrive. When I tried Plex The wintv tuner card where not recognize. The chmod -R 777 /dev/dvb command had to be reused and --device=/dev/dvb:/de/dvb must also be added to the run command. At this time everything works I have device=/dev/dvb:/de/dvb in the docker create and docker run