Plex setup wizard only shows access denied

Hey there,
I installed the linuxserver plex docker container on a Synology NAS using the built in registry and Docker management app provided by DSM. Networking is set to host mode.

When I access http://[ip:32400/web it asks for my Plex account, signs me in and then switches to a page only showing that access to the server was denied. In the server log I only see that the container was started.

The latest message is:
“Starting Plex Media Server.”

The messages above contain no errors, only a warning about not doing automatic updates (this is mentioned in the guide on docker hub, fine).

I played around with the PUID and PGID Parameters. They are set to the same user as the one I’m using to log into the DSM UI. I can see that the config directory I mounted is populated with files and they are owned by the same user and group as intended with the PUID and PGID parameters. So I’m not sure that it means those permissions.

I guess what I’m stuck on is that I don’t even know what exactly I’m denied permission when trying to start the server wizard.

Here are the settings used:

Can anyone point me in the right direction here?

I got it working, though I can’t say how. It wasn’t working yesterday as described, but today the server showed up in the WebUI as offline. I turned on the container and suddenly I could connect and do the setup wizard. I tried a lot of different things yesterday, but nothing worked then, so I dunno why it works now or to which try it was connected to. Sorry I can’t specify it more in case someone comes across this post in the future with similiar issues.