Plex unable to load core plugins (host and bridge)

Hello, I am trying to spin up an instance of plex on an old laptop (runnung ubuntu 20.04) on my LAN using the linuxserver image. I initially tried to use bridge networking so I could access it behind a proxy. However after discussing on the plex forum I know that setting up behind proxy is not always possible. So I have tried with host networking to the same result, which is that the browswer hits the “setting up server” screen and eventually returns “A problem has been detected with a core component of Plex Media Server” error.

This is a link to the plex discussion with a team member which has all my logs linked (cant link them here)

The root of it seems to be that all of the core plug-ins are unable to load. The docker logs show the service starting and then immediately start giving

Error starting framework core for /usr/lib/plexmediaserver/Resources/Plug-ins-c8bd13540/PlexMovieNew.bundle.
Error starting framework core for /usr/lib/plexmediaserver/Resources/Plug-ins-c8bd13540/TheMovieDB.bundle.     
Error starting framework core for /usr/lib/plexmediaserver/Resources/Plug-ins-c8bd13540/LocalMedia.bundle.
(and more...)

If I follow this to the PMS plugin logs, I see that each of the named services in error has the same message when tailing the logs.

  File "/usr/lib/plexmediaserver/Resources/Python/", line 429, in open                  
    response = self._open(req, data)                                                                           
  File "/usr/lib/plexmediaserver/Resources/Python/", line 447, in _open                 
    '_open', req)                                                                                              
  File "/usr/lib/plexmediaserver/Resources/Python/", line 407, in _call_chain           
    result = func(*args)                                                                                       
  File "/usr/lib/plexmediaserver/Resources/Python/", line 1228, in http_open            
    return self.do_open(httplib.HTTPConnection, req)                                                           
  File "/usr/lib/plexmediaserver/Resources/Python/", line 1198, in do_open              
    raise URLError(err)                                                                                        
URLError: <urlopen error [Errno 111] Connection refused>

Again this happens for both bridge and host networking, and I am not sure what to try next. Any help would be greatly appreciated!

Can you please share your docker compose or docker run command used to create the container? Also include full docker logs