Pls some help with Transmission (latest) and unrar script


I unfortunately had to reinstall my QNAP Containerstation and my backup Docker with Transmission (not Linuxserver) did not want to start. So I started fresh with the latest docker from Linuxserver.
Now almost everything works. Downloading, watch folder etc etc.

But for the life of me I can’t get my unrar script working (which worked in my old (timhaak) Transmission Docker).
The script gets called by Transmission after a download completes but gives my different errors.

My old script did not have a SHEBANG (and worked).
But now without a shebang I get the error
Error executing script “/config/” (8): Child process setup failed: Exec format error

With #!/bin/sh or #!/bin/bash comes
Error executing script “/config/” (2): Child process setup failed: No such file or directory

Only with #!/usr/bin/env bash the script gives no errors in the docker log but does nothing.

script for testing:
#!/usr/bin/env bash
date >> “/config/unrar.log”
printf “test” >> “/config/unrar.log”

This unfortunately does not create an unrar.log file. The script is set to be executable.
Does anyone have a unrar script that is working with latest transmission docker?


I would suggest asking the transmission people, this sounds pretty far outside of our scope. You could also come on discord and ask in #other-suppose if you like.

I would suggest checking the script and see what application it calls.
If your QNAP has an ARM64 cpu and the script calls an AMD64 application (or other way around), this will not work and result in an “Exec format error’”.

This is only an educated guess by the info.