Problem building Radarr

Hello everyone,

I am having a problem building the LSIO Radarr erroring out on a code 35. It appears to be coming from this part of the code.

if [ -z ${RADARR_RELEASE+x} ]; then \
    RADARR_RELEASE=$(curl -sL "${RADARR_BRANCH}/changes?runtime=netcore&os=linuxmusl" \
    | jq -r '.[0].version'); \
  fi && \

Building on ubuntu 22.04… Any ideas?

are you wanting us to guess why you’re building and what the error is?

my guess will be you didn’t install curl and/or jq.

the error will be “curl: command not found”

do i win anything?

Wow, first time posting on here for help and that is the kind of reply you get… nice… well lets see…

  1. Because I want to and can according to the docs and the error is exit code 35 as stated.
  2. Bzzzz wrong answer but hey thanks for playing.
  3. All my distro packages are installed and up to date. Sonarr and other packages build just fine.
  4. Maybe the URL to the community guidelines?

Now, curl error 35 is defined as: In short, the cURL error code 35 denotes an SSL connection error . Generally caused by server timeouts, misconfigured servers or out of date servers. It could quite possibly be out dated cURL as well, however I have eliminated that possibility. This may be out of LSIO’s control, however this is the place I chose to start at since it is their Dockerfile.

Thanks… And if anyone else has any other ideas I’d love to get this fixed.

Honestly, you didn’t provide any info other than you’re building the LSIO Radarr.

Rather than being sarcastic, you can give us more background info, what your environment is, what commands you used, etc.

As you can see, our CI builds it just fine: Jenkins

At least in their sarcasm they mentioned curl was what is generating the “code 35”


I followed the instructions on dockerhub. Specifically the these.

Building locally
If you want to make local modifications to these images for development purposes or just to customize the logic:

git clone
cd docker-radarr
docker build \
  --no-cache \
  --pull \
  -t .

And the error is this

curl: (35) Recv failure:
The command '/bin/sh -c echo "**** install packages ****" &&   apk add -U --upgrade --no-cache     icu-libs     sqlite-libs &&   echo "**** install radarr ****" &&   mkdir -p /app/radarr/bin &&   if [ -z ${RADARR_RELEASE+x} ]; then     RADARR_RELEASE=$(curl -sL "${RADARR_BRANCH}/changes?runtime=netcore&os=linuxmusl"     | jq -r '.[0].version');   fi &&   curl -o     /tmp/radarr.tar.gz -L     "${RADARR_BRANCH}/updatefile?version=${RADARR_RELEASE}&os=linuxmusl&runtime=netcore&arch=x64" &&   tar xzf     /tmp/radarr.tar.gz -C     /app/radarr/bin --strip-components=1 &&   echo -e "UpdateMethod=docker\nBranch=${RADARR_BRANCH}\nPackageVersion=${VERSION}\nPackageAuthor=[](" > /app/radarr/package_info &&   echo "**** cleanup ****" &&   rm -rf     /app/radarr/bin/Radarr.Update     /tmp/*' returned a non-zero code: 35

And I am running ubuntu 22.04 with all packages up to date.

If you read the first line of my original post it stated its erroring out on code 35. The posted code indicates it is cURL generating the error.

Reread it huh :stuck_out_tongue: (ah apparently not, sad)

What you’ve now provided is much better detail.

Usually an error on build is color coded, did you see anything of the sort?

Can you run that line on your host successfully?

Uh, nope, just replied to the wrong person… :confused:

That error I posted is in Red.

And no, if I run that command from the command line “replacing the variables with the proper settings” I still get the same error.

To the best of my knowledge this is how the command line should look.


And this is the output…

[1] 150442
myUser@kodiak:~/src/docker-radarr$ curl: (35) OpenSSL SSL_connect: Connection reset by peer in connection to

[1]+  Exit 35                 curl

if you can’t run it on the host, you have to fix that first.
for example:

lsio-dev ~ # RADARR_RELEASE=$(curl -sL "" \                                                                                         | jq -r '.[0].version')
lsio-dev ~ # echo $RADARR_RELEASE

ok just saw your update, are your ca-certificates and openssl up to date?

As far as i know. I ran a full update already. I will check the distro version when i get back to the office. Maybe ubuntu is behind…

could be their snap BS too, ill spin up an ubuntu vm and test

Maybe thats the issue. I still use apt.

no thats good, you should use apt and never fall into the snap trap.

got ubuntu up and it’s still good for me

root@test:~# RADARR_RELEASE=$(curl -sL "" | jq -r '.[0].version')                                                           
root@test:~# echo $RADARR_RELEASE
root@test:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 22.04.1 LTS
Release:        22.04
Codename:       jammy
root@test:~# uname -mr
5.15.0-69-generic x86_64

All my info matches yours.

apt-show-versions | grep curl
curl:amd64/jammy-security 7.81.0-1ubuntu1.10 uptodate
libcurl3-gnutls:amd64/jammy-security 7.81.0-1ubuntu1.10 uptodate
libcurl4:amd64/jammy-security 7.81.0-1ubuntu1.10 uptodate

 apt-show-versions | grep ca
ca-certificates:all/jammy-security 20211016ubuntu0.22.04.1 uptodate

I am at a loss here, this is the only dockerfile that I have this issue with so far.

Did you check dns? Pihole?

@aptalca You read my mind.

I do not use dns filters or piHole. However I do use Meraki routers. Upon checking log files it was being blocked. The 1st mistake I made was I never moved that machine out of the content filter range. Second issue is raddarr i think is misclassified for some reason it is classified as:

Results for your request:
Categories:	Business
Alexa Rank:	n/a

As to where Sonarr is classified as

Results for your request:
Categories:	Computers & Technology
Alexa Rank:	n/a

Both taken from a category checker off the net so who knows its reliability. The funny thing is, I do not have Business being blocked in the content filter so maybe the Meraki has it as a different classification I may dig through the logs later to validate that. Right now it just says “Blocked - Categories”.

After moving the machine out of the content filter range it works as it should now. Downloads and builds correctly.

@driz Sorry for the rough start, I just didn’t think that reply was appropriate. You’re all right in my book… Both of you.

Thanks again for the help now back to what I was doing…

Glad it’s resolved (pun intended).