Qbittorrent Host not found (authoritative) and timed out

First, just want to say thank you for all your work on these.

I’m running a combo of Gluetun + ProtonVPN + qBittorrent all in separate Docker containers on my QNAP. The problem I’m facing is torrent speeds on qBittorrent are incredibly slow and it appears to not find many trackers. Messages include host not found, timed out, and skipping tracker announce (unreachable). Not sure what else I need to configure or if I’ve misconfigured anything. Thank you very much!

Here’s everything I’ve tried:

  1. I’ve tried various locations on ProtonVPN. Doesn’t appear to be related to locations.
  2. The listening port on qBittorrent is 47576 and I’ve inserted that number in FIREWALL_VPN_INPUT_PORTS on Gluetun.
  3. Network Interface on qBittorrent is set to tun0
  4. Optional IP address to bind to All IPv4 on qBittorrent.
  5. Disabled “Validate HTTPS tracker cert”

Here’s part of my Docker compose:

version: '3.9'

    image: qmcgaw/gluetun
    container_name: vpn
      - NET_ADMIN
      - VPN_TYPE=wireguard
      - VPN_ENDPOINT_IP=redacted
      - VPN_ENDPOINT_PORT=51820
      - WIREGUARD_PUBLIC_KEY=redacted
      - WIREGUARD_PRIVATE_KEY=redacted
      - DNS_ADDRESS=
      - FIREWALL_VPN_INPUT_PORTS=47576,6881
      - 8888:8888/tcp # HTTP proxy
      - 51820:51820 # VPN
      - 8388:8388/udp # Shadowsocks
      - 8388:8388/tcp # Shadowsocks
      - 8282:8282/tcp # qbittorrent
      - 6881:6881 # qbittorrent
      - 6881:6881/udp # qbittorrent
      - 47576:47576 #qbittorrent

    image: lscr.io/linuxserver/qbittorrent:latest
    container_name: qbittorrent
      - PUID=1000
      - PGID=1000
      - TZ=America/New_York
      - WEBUI_PORT=8282
      - /share/data/config/qbittorrent:/config
      - /share/data/downloads:/downloads
    network_mode: service:vpn
      - autoheal=true
      test: curl google.com || exit 1
      interval: 30s
      timeout: 10s
      retries: 3
      - vpn
    restart: unless-stopped

Don’t let me get your hopes up, I’m running into a similar issue but with NordLynx. My setup has some similarities with this github, and I just started using the scripts for health checks. But sadly still “host not found” errors. I would love it if anyone else can figure out what’s going on when running into this.

My Nord LYnx docker container shows itself as connecting to a vpn server successfully, and QBittorrent is correctly configured to the Network interface. And from QBitorrent logs I can verify it’s using wg0 network interface once I got the QBitorrent service to start after NordLynx has a valid healthcheck. No idea what’s getting dropped here.

I stopped my firewall and host tailscale in case they were interfering, but that didn’t help.

I tried pruning my docker containers/images/volumes/everything; didn’t help. I tried deleting my torrent configs and starting from scratch; didn’t help.

This error just seemed to “randomly” start happening for me.