qBittorrent: How to disable chown on startup?

Hi, I’m running the qBittorrent docker image – which works fine, but my issue is that it insists on trying to chown all my downloaded files when starting. The files are on an NFS share, and qBittorrent is not allowed to change the owners (and does not need to. It has full read/write permission)

chown: changing ownership of '/downloads/completed/directory-name/file.ext': Operation not permitted

How do I disable this behavior that adds I/O to my system and slows down the container startup?

Thanks

you’d need to fork the repo and remove the chown; note you’ll also need to fork the baseimage and remove the chown there as well.

we do not offer support for remote mounts.

Thanks for the answer!

Shouldn’t it be possible to add a flag/label to skip the chown all together, while keeping it as a default? I can’t be the only one using a remote mount point?

Or have a quick test of permissions to decide if chown is needed?

No
I use remote mounts, but I set them up right :stuck_out_tongue:
Sure, you can fork both repos and modify the chown to check if it’s needed

I have a ZFS NFS share via an OmniOS VM, and the permissions are set via ZFS ACL. This directory has drwxrwxrwx+ – basically no restrictions.

Do you have any suggestions on how to do it better?

And do you think it’s a bad idea to have a flag on the official images?

we won’t add any flags
I (nor the rest of the team) don’t offer support for proper configuration of NFS, it’s heavily documented.

that said, I believe I provided the answers to your question of how to disable chown on startup

You aren’t the only one using remote mount points. I’m also using ZFS ACLs, mounted via NFS, and the files have the same ownership/group membership as the UID and GID container environment vars. I’ve accepted that it’s just going to be a slow startup every time.