Qbittorrent not accessible. No idea why

Hi folks!

I run a few docker containers from linuxserver which I installed via Portainer Stack. No issues. I am trying to run qbittorrent via the same method. But I cannot access the Web GUI. This site can’t be reached.

Any idea what to do to make it work?

The log does not seem to show any errors. Or maybe I misinterpret. This is the log:

[custom-init] No custom services found, skipping...
[migrations] started
[migrations] no migrations found
          _         ()
         | |  ___   _    __
         | | / __| | |  /  \
         | | \__ \ | | | () |
         |_| |___/ |_|  \__/
Brought to you by linuxserver.io
To support LSIO projects visit:
https: //www. linuxserver .io/donate/
User uid:    998
User gid:    100
[custom-init] No custom files found, skipping...
******** Information ********
To control qBittorrent, access the WebUI at: http:// localhost :8088
[ls.io-init] done.

And this is the stack / docker compose I created:

version: "2.1"
    image: lscr.io/linuxserver/ qbittorrent:latest
    container_name: qbittorrent
      - PUID=998
      - PGID=100
      - TZ=Europe/Bucharest
      - WEBUI_PORT=8088
      - /opt/qbittorrent/config:/config
      - /srv/dev-disk-by-uuid-2c9bd64d-ab80-4606-a084-b6ee55757a45/OMV_Database/Downloads:/downloads
      - 8088:8080
      - 6881:6881
      - 6881:6881/udp
    restart: unless-stopped

Thank you so much!

PS: I left spaces in between links because I cannot post this otherwise because of restrictions.

According with the info regarding setup of qbittorrent presented here I see that If I have no webui , I should check the file /config/qBittorrent/qBittorrent.conf

edit or add the following lines



I checked the file and it seems I have those lines of code like this:




Should I modify them?

You should follow the readme always. Specifically it tells you

yet you set webui_port to 8088, then in port mapping, you set 8088:8080 which is NOT what the readme says to do. If you modify per the readme it will work.

Ah! Wow! I misinterpreted that one as it is the first time I encounter this situation. Usually it clearly states that one should never change the second port.

Thank you, driz. That solved the issue!!

My pleasure, glad you got it sorted. We have a couple containers like this that require changing that right side, but generally speaking, you are correct that usually you leave it alone.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.