qBittorrent Nox lost all of my torrents after moving config folder

I moved my /config folder on my qBittorrent Nox docker container, which caused everything inside my qbittorrent Nox to disappear completely, hundreds of torrents wiped out. I copied the original config files from the previous location directly onto the new location of /config, but still it seems like all my stuff is gone.

How do I load my stuff back in?

You’ve not provided enough info for us to help you. I suggest providing your original compose and your updated compose (with new /config path)

The current compose is this:

version: "2.1"
    image: lscr.io/linuxserver/qbittorrent
    container_name: qbittorrent
      - PUID=1000
      - PGID=100
      - TZ=Mexico City
      - WEBUI_PORT=8080
      - /home/drambit/.config:/config
      - /srv/dev-disk-by-uuid-84475483-4c80-4f1d-a765-e6918b958631/Torrents:/Torrents
      - 8080:8080
      - 6881:6881
      - 6881:6881/udp
    restart: unless-stopped

The previous one was identical in all ways except that the path for /config was " - /AppData/qbittorrent:/config". All I have done is move the config path and then execute "cp -r “/AppData/qbittorrent” “/home/drambit/.config”.

I tried changing the path back to the previous one and it all my information filled back in to qbittorrent right away, perhaps I copied it incorrectly to the new location?

could be some symlinks or something (i dont personally use qbit so i dont know the structure there) perhaps try rsync instead?

rsync -avhLK /AppData/qbittorrent /home/drambit/.config
and see if it yields better results?

I tried your command exactly, it seems to have gone off without a hitch, but after changing the location of the config in the compose it has gone back to being wiped again. Must be something weird going on here.