Radarr not accessible on raspberry

Hey Guys,

I’m trying to setup radarr with the following command:
docker create
-e PUID=1000
-e PGID=995
-e TZ=Europe/Rome
-e UMASK_SET=002 #optional
-p 7878:7878
-v /home/pi/docker/radarr-v3:/config
-v /home/pi/docs/film_test:/movies
-v /home/pi/downloads:/downloads
–restart unless-stopped

everything fine but I cannot access the webpage when running the docker.
curl on localhost 7878 gives me
curl: (52) Empty reply from server
the same when querying from another client on the same lan

Container version number:
Linuxserver.io version:- v0.2.0.1480-ls52 Build-date:- 2020-02-25T01:15:51-05:00
and nothing really relevant from the logs

Am I missing something?

Thanks in advance,

I’ve found the logs in the meantime.
Have you started the container, or just created it with the above command?
You don’t need to use the architecture, it’s enough if you use linuxserver/radarr:latest. But for radarr v3 you need linuxserver/radarr:preview.

I run it using portainer application, it’s look like it is up and running as I can see something is listening at port 7878.
I also tried to change the host port to 9001 but nothing happened, I cannot load the webpage :frowning:

Another test using docker compose, with the following file, as you suggested I used the
image again, without any success.

image: linuxserver/radarr:latest
container_name: radarr
- ${USERDIR}/docker/radarr:/config
- ${USERDIR}/docs/transmission/completed:/downloads
- ${USERDIR}/docs/film:/movies
- “/etc/localtime:/etc/localtime:ro”
- ${USERDIR}/docker/shared:/shared
- “9001:7878”
restart: always
- PUID=1000
- PGID=995
- TZ=Europe/Rome

Please try this command and paste here the output, if it won’t work.

docker run --rm
-e PUID=1000
-e PGID=995
-e TZ=Europe/Rome
-p 7878:7878
-v /home/pi/docker/radarr-v3:/config
-v /home/pi/docs/film_test:/movies
-v /home/pi/downloads:/downloads

Have you tried using your host ip rather than localhost?

1 Like

seems like nothing really wrong…

[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] 01-envfile: executing…
[cont-init.d] 01-envfile: exited 267.
[cont-init.d] 10-adduser: executing…
[cont-init.d] 10-adduser: exited 267.
[cont-init.d] 30-config: executing…
[cont-init.d] 30-config: exited 267.
[cont-init.d] 99-custom-scripts: executing…
[cont-init.d] 99-custom-scripts: exited 267.
[cont-init.d] done.
[services.d] starting services
[services.d] done.

Thanks for the reply, I got connection reset by peer :frowning:

Could you try it with an earlier version?

I got the problem, I was building it on raspberry pi 1, which seems to be not supported.
I tried it on raspberry pi 3 and everything is fine!
Sounds strange that no relevant logs were present.


This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.