Radarr:preview (arm) - server not running


I’m using radarr:preview with regular updates for a quite while with no problems, but since couple of weeks ago (somewhere around July 22nd) I’m experiencing the situation when the docker container starts, but the radar server (mono) is not running, therefore connection on port 7878 gets refused. I’ve tried to create a new container from the latest image but got the same results.
Any ideas? :slight_smile:

Radarr has no new entries in the log.

Host: RaspberryPi 4 with Raspbian

Docker container log:
pi@rasplex:~ $ sudo docker logs -f radarr_pasteur
[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] 01-envfile: executing…
[cont-init.d] 01-envfile: exited 0.
[cont-init.d] 10-adduser: executing…
usermod: no changes

          _         ()
         | |  ___   _    __
         | | / __| | |  /  \
         | | \__ \ | | | () |
         |_| |___/ |_|  \__/

Brought to you by linuxserver.io

To support the app dev(s) visit:
Radarr: https://opencollective.com/radarr

To support LSIO projects visit:

User uid:    911
User gid:    911

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 30-config: executing...
[cont-init.d] 30-config: exited 0.
[cont-init.d] 90-warning: executing...

*                                                    *
*                                                    *
*         This image is for development only         *
*                                                    *
*              Use at your own peril                 *
* It will likely have bugs and not function properly *
*                                                    *
*                                                    *
[cont-init.d] 90-warning: exited 0.
[cont-init.d] 99-custom-scripts: executing...
[custom-init] no custom files found exiting...
[cont-init.d] 99-custom-scripts: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.


i guess for starters I’ll say, we do not offer support of any kind for dev branches.

I’ll follow that up with you are not properly passing your PUID/PGID to your container (that’s why you see 911)

I would correct the puid/pgid issues, blow away what you have and redeploy and see what happens, otherwise, you probably want to ask the radarr team.

1 Like

Just a note - the PID GID is not a problem, because I’ve already and was successfully using its mapping before:
I’ll try to ask on the Radarr discord then.

Thanks for maintaining those images! :slight_smile:

The problem is likely libseccomp, where older versions cause issues with docker on arm with ubuntu 20.04.

Radarr preview uses ubuntu 20.04 as the baseimage. So you’ll either have to install the latest ubuntu libseccomp package on your raspbian host, or use radarr stable, which is ubuntu 18.04

BTW: I’ve just tried to use the hotio/radarr:aphrodite and it works without a problem. So it doesn’t seem the problem is on the Radarr side.

We can only go off what you provide and your logs show a puid/pgid issue; sounds like you swapped and it works, so we’ll consider this resolved.

If you plan to use our image, please follow Aptalca’s guidance and then let us know

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.