Rtorrent not adding files from the watch folder

I’m trying to re-add my torrent files (2k or so so way too much to add from the webui) from my backup and rtorrent is not grabbing files from the watched folder. I also tried adding a watched folder in rutorrent autotools, which also does nothing when I ftp my torrent files into it

    image: linuxserver/rutorrent
    container_name: rutorrent
      - PUID=1000
      - PGID=1000
      - /home/someguy/rutorrent/config:/config
      - /home/someguy/rutorrent/downloads:/downloads
      - /home/someguy/rutorrent/downloads/watched:/watched
      - 8080:80
      - 5000:5000
      - 51413:51413
      - 6881:6881/udp
    restart: unless-stopped

Any idea what I’m doing wrong here? Do I need to add something to rtorrent.rc? It is currently the default I believe:

Required for ruTorrent

execute2 = {sh,-c,/usr/bin/php7 /app/rutorrent/php/initplugins.php abc &}
execute.nothrow = rm,/run/php/.rtorrent.sock
network.scgi.open_local = /run/php/.rtorrent.sock
schedule2 = socket_chmod,0,0,“execute=chmod,0660,/run/php/.rtorrent.sock”
schedule2 = socket_chgrp,0,0,“execute=chgrp,abc,/run/php/.rtorrent.sock”


log.open_file = “rtorrent”, /config/log/rtorrent/rtorrent.log
log.add_output = “info”, “rtorrent”


throttle.min_peers.normal.set = 40
throttle.max_peers.normal.set = 1200
throttle.max_uploads.global.set = 15

Optionally, set this per torrent:

throttle.max_uploads.set = 5


schedule2 = watch_directory_1,5,5,“load.start=/downloads/watched/*.torrent”

directory = /downloads/incoming
session = /config/rtorrent/rtorrent_sess
method.insert = d.get_finished_dir, simple, “cat=/downloads/completed/,$d.custom1=”
method.insert = d.data_path, simple, “if=(d.is_multi_file), (cat,(d.directory),/), (cat,(d.directory),/,(d.name))”
method.insert = d.move_to_complete, simple, "d.directory.set=$argument.1=; execute=mkdir,-p,$argument.1=; execute=mv,-u,$argument.0=,$argument.1=; d.save_ful$
method.set_key = event.download.finished,move_complete,“d.move_to_complete=$d.data_path=,$d.get_finished_dir=”

Stop torrents when your drive has <100M free disk space

schedule = low_diskspace,5,60,close_low_diskspace=100M


network.port_range.set = 51413-51413
network.port_random.set = no

Downloading settings

pieces.hash.on_completion.set = yes
protocol.encryption.set = allow_incoming,try_outgoing,enable_retry

DHT / PEX settings

set to “disable” to disable

dht.mode.set = auto
dht.port.set = 6881

set to “no” to disable

protocol.pex.set = yes

set to “no” to disable

trackers.use_udp.set = yes

encoding.add = utf8

I did figure it out, and it was entirely my fault.

To anyone else reading this in the future because they made the same bonehead mistake as me, my /watched path wasn’t correct. I made the mistake of putting /home/someguy/downloads/watched when of course the rtorrent docker image just sees /downloads/watched.