Running windows setup in netboot.xyz

Request for help: I’m trying to use netboot.xyz to install windows over lan and I can’t for the life of me figure out how. I can get any linux distro to boot and install just fine so the container seems to be running okay afaik.
In search of trying to find an answer/guide/walkthrough/anything I’ve finally found a post on this forum on a tangent matter explaining how to do so but unfortunately the info in it is to sparse for me.

Netboot.xyz docker container > how to see my custom ISO to boot off of

"Assuming you’re still talking about windows:

  1. mount your ISO (or unpack it) in a samba share
  2. Verify you can see all the files via the built in http server.
  3. boot the windows install environment
  4. enable networking
  5. mount the samba share to a drive letter
  6. run setup.exe from the share

this is basically how WDS works as well. if your links are too slow to handle this, deploy with usb?"

I got 1 and 2 but when at point 3, I’m assuming this is the method described in the netbootxyz menu? If not I don’t know what this means (winpe?).
But if it does, how to go about point 4?

Any help would be very much appreciated.

wpeinit = 4 – you need to know some dos commands.

booting windows from pxe isn’t, never has been, and never will be easy. just like booting linux from wds isn’t simple.

winpe is irrelevant, it’s a preinstallation environment, much like when you first boot off the windows 10 iso.

Much obliged. I managed to run all 6 steps using your pointer.
However my problem that caused to go look for help in the first place remains thesame even using your guidelines: Setup hangs at the starts stating it can’t find a media driver (without specifying which one, very helpfull) even though the full contents of the iso are unpacked and accessible on the samba share.
Thanks for the help but I think I need to look in another direction first not directly related to netboot.xyz

when you install windows from disc or usb, do you have this same driver issue?

can you show a picture of the error you encounter?

The error it throws seems to be fairly well known.

driver
According to the web the most common solution is replugging the USB install stick in a different port which is a tad difficult with it being a LAN install.
Another possible cause would be a corrupted iso so I redownloaded it again with the MS media creator tool but that made no difference. I tried it with an iso of windows 7 as well I have laying around but that gave me the same error which made me believe I wasn’t mounting them properly. Hence my earlier question.

Unfortunately I don’t have an USB stick big enough at hand to strike off that possibility. It’s one of the reasons I wanted to do this over LAN. Same with a cd, I don’t even have a drive let alone a burner.

it’s like the old press f6 to load hard drive drivers thing. but this takes us back to my original question, have you ever installed from a cd or usb where you didnt get prompted for a driver? If the answer is no, you just need to add the driver into your unpacked iso. it should be easy to find some instructions to bake it in.

just keep in mind, you don’t necessarily need to repack into iso since you need it extracted for use anyway

I’ll give that a whirl, thanks. I’ll let you know

As a response to your original question. Did I get prompted for the driver when installing from an USB stick? The answer would be no I did not. And it wasn’t media tool or rufus created either. Simply copied the contents from the ISO to the USB and it installs just fine. So I’m led to believe again something doesn’t get loaded juuust right from LAN?
Also is this such a niche usecase nobody else seem to have trouble with this?

there are not a WHOLE lot of users using netboot for windows because it’s a bit of a pain; wds does all this hard work for you. that said, I’ve never seen this issue where it didn’t also present via usb/disc install.

I’ll be honest, at this point, I couldn’t say what’s causing your issue. with windows on netboot, there are a few moving parts so it is quite a bit more complex since it involves loading over http and then loading over samba.

so I’ve noticed :laughing:
in any case, I’m going to look into WSD based solutions then, this is proving to be more of a hassle than it’s worth
thank you for your time and effort /salute

best of luck man, wds will definitely make it easier, just keep in mind, getting linux to boot from wds is an even worse nightmare :confused: