Sabnzbd hard coded to use port 8080?

I was recently trying to get sabnzb to run on a port other than 8080 and after doing a bit of research I noticed that the file /run/s6/services/sabnzbd/run has a hard coded value of 8080. Any chance of changing this to use an ENV variable?

No, you can map it to whatever port you like in docker arguments

all that does is change the external port - I am looking to change the internal port so that it can match the sabnzbd.ini file settings I am using. Is there a specific reason its hard coded?

Why?. . . . . . . . .

I have a number of instances running that have a ini file that is auto generate – some are behind proxies, some are running on docker.

if your really set against allowing it to use what is in the ini file, I can take a look at updating the run file using the custom config (love how this is possible).

We have no plans to modify how the container works currently, but you are more than welcome to modify it according to your needs.

the link above can help you ensure you can continue to pull our latest updates while maintaining your custom needs.