[Solved] Callibre-web test-email issue on Synology-Docker

Hello, fairly new to all this docker stuff, but I love your images. Ran into a problem though… here goes.

System Setup:
Docker version Standalone 18.09.8 running on a Synology DS1520+ (Intel Celeron J4125)
Portainer 2.1.1 used to install calibre-web
Callibre-web Version: | 0.6.11 |Current version|

Here is the compose file:

version: “2.1”
services:
calibre-web:
image: ghcr.io/linuxserver/calibre-web
container_name: calibre-web
environment:
- PUID=1038
- PGID=100
- TZ=Europe/Berlin
- DOCKER_MODS=linuxserver/calibre-web:calibre
volumes:
- /volume1/docker/calibre-web/config:/config
- /volume1/docker/calibre/config/Calibre Library:/books
ports:
- 8083:8083
restart: unless-stopped

PUID=1038 is the dockeruser I use for all the rights… made sure in synology interface that he is the owner of the folders.

When does the issue occur:
I configure the SMTP server and click on send test-email. It confirms the testmail, and if I click on tasks I can see the task. It sits at 0% for exactly 10 seconds and then jumps to “failed” with a 100% progress setting. Always exactly 10 seconds.

The Calibre docker container is stopped by the way.

I have switched the log to debug, but there seems to be awfully little in it.
image
and here the logs that I get when I click on the view log button:
[2021-02-28 20:23:59,400] INFO {cps:101} Starting Calibre Web…
[2021-02-28 20:23:59,538] INFO {cps.server:146} Starting Gevent server on [::]:8083
[2021-02-28 20:24:18,535] DEBUG {cps.config_sql:323} _ConfigSQL updating storage
[2021-02-28 20:24:46,341] DEBUG {cps.config_sql:323} _ConfigSQL updating storage

and thats it.
I have tried multiple other email services (Google with app password, gmx), I just can’t get it to work.

Maybe two more things, though I don’t know if relevant. I am currently not at the same place as the machine so I am logged in via an OpenVPN that is running on the same synology to access the portainer and the synology web UI.
Also I am using the Synology internal reverse proxy to have the synology ip:8083 mapped to ebooks.mydomain.com, for which I have a working LetsEncrypt certificate (green padlock when I access calibre-web). Issue persits no matter if I use the VPN or the reverse proxy to access calibre-web.

I sincerely hope this is all information needed.

Sorry, to have bothered you guys. As usual the issue is in front of the PC.
I had the Firewall on the Synology configured to block all traffic unless specifically allowed. If I look up the IP of the calibre-web container (172.24.0.2 in my case) and add a rule to allow all ports for this IP everything works.
Hopefully this post can help people realise if they make the same mistake.