SOLVED - qBittorrent category shows "undefined"

Hi, first of all thanks for the effort and amazing job you are doing!

I’m using the latest docker image of qBittorrent and I’m experiencing problems when using the “category” feature. Docker runs on an Ubuntu Server 20.04.3. I’ve tried with a native installation of qBittorrent, and the problem does not happen.

I’ve created a category called “sonarr” that points to “/downloads/downloads/sonarr” (the path is correct and it exists).

I click “Add” to save the category. If I try to edit the category, the “Save path” field is empty:

If I try to add a torrent manually and select “sonarr” as category, I see the following:

When the torrent finishes downloading, the web UI becomes unresponsive and on the bottom I see a red text in bold saying “qBittorrent is not reacheable.” If I refresh, I see the torrent started downloading again from scratch.

The log shows the following line:

(N) 2022-01-22T16:12:37 - Couldn’t enqueue move of “name_of_my_torrent” from “/downloads/downloads/qbittorrent/temp” to “/downloads/downloads/qbittorrent/temp”. Both paths point to the same location.

Do you guys have an idea on this?

Apparently this is a known issue at qBittorrent:

It will be fixed in version 4.4.1. I downgraded to 4.3.9 and now things work as expected.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.