Sonarr and Sabnzb trouble Import fail

sabnzbd
sonarr

#1

Hi everybody, newbie on Dockers but what i have seen so far o love it.
Running Sonarr and Sabnzb on a Raspberry Pi working great, now i wanna do one with dockers , because i can:) (I thought)

sudo docker create \

–name=sabnzbd
-e PUID=1001
-e PGID=1001
-e TZ=Europe/London
-e TZ=Europe/London
-p 8080:8080
-p 9090:9090
-v /mnt/cache/appdata/sabnzbd:/config
-v /mnt/cache/appdata/Downloads/complete:/downloads
-v /mnt/cache/appdata/Downloads/incomplete:/incomplete-downloads
–restart unless-stopped
linuxserver/sabnzbd

sudo docker create \

–name=sonarr
-e PUID=1001
-e PGID=1001
-e TZ=Europe/London
-p 8989:8989
-v /mnt/cache/appdata/sonarr:/config
-v /media/networkshare/public:/tv
-v /mnt/cache/appdata/Downloads/complete:/downloads
–restart unless-stopped
linuxserver/sonarr

Been Googling like crazy and this is my setup just now, but i still get :
Import failed, path does not exist or is not accessible by Sonarr

I get that Dockers is like separate computers , but i would like to think i mapped to same folder.
The files i downloaded

I would like to understand what im doing wrong


#2

Volume mapping looks correct, so is the PUID set.

The issue might have to do with the location sonarr is trying to move the media to.

Check the permissions on /media/networkshare/public to make sure it is owned by PUID 1001 and/or user 1001 has write access to it


#3

Thx for quick response!!

//192.168.1.5/video /media/networkshare/public cifs username=,password=***,rw,iocharset=utf8,vers=1.0,file_mode=0777 0 0

this is from fstab


#4

drwxrwxrwx 8 root root 0 Feb 21 16:11 /media/networkshare/public/


#5

Try docker exec -it sonarr ls -al /tv
If that all looks good, then I don’t know.
I’m not entirely sure about how smb mount points are handled in sonarr or docker when it comes to users really. I use nfs mounts for media, but the user owner is the same on both servers


#6

pi@raspberrypi:/ $ sudo docker exec -it sonarr ls -al /tv
total 4
drwxrwxrwx 8 root root 0 Feb 21 16:11 .
drwxr-xr-x 1 root root 4096 Mar 2 16:27 …
drwxrwxrwx 4 1026 users 0 Jan 24 13:28 Barnfilm
drwxrwxrwx 667 1026 users 0 Mar 1 06:24 FILM
drwxrwxrwx 134 1026 users 0 Mar 2 19:36 NYTV
drwxrwxrwx 72 1026 users 0 Feb 21 18:28 OLDTV
drwxrwxrwx 3 1026 users 0 Feb 21 17:42 Test


#7

When i try to “manualy” move the file, Sonarr cant see the file, so i still feel that Sonarr does not have the right permission in the Sabnzb docker.
I tried to move the endlocation to the raspberry did not help.
I want to understand:)!!!


#8

When i check in Sabnzb , looking att the file i downloaded its located:
/config/Downloads/complete/Homeco*********
Hmmmm, going Crazy…:slight_smile:


#9

in sab, you need to set the download location to /downloads not Downloads, pay attention to two things there: difference in uppercase/lowercase and absolute vs relative path


#10

mnt


#11

You have very similarly named paths and you are confusing yourself.

Go to your sab webgui, click on config, then Folders. Then read my last post above


#12

folder


#13

Now i have changed it


#14

Thx m8 for trying to help, i agree that the naming is confusing.


#15


#16

you forgot the / in the beginning. That’s needed for absolute path. Without it, sab just creates a folder with that name in its home (config) folder

so set that to /downloads/complete


#17

OMG!!! Thx m8
It was the /downloads/complete,
Its confusing , for a newbie
But finally it works