Sonarr not brows able

I have a VM on Windows 10 running Unbuntu 18.04. It’s a new install and so far I have Portainer, Jellyfin, Radarr, QBittorrent etc all running without much issue.

I’ve installed the linuxserver/sonarr container, like I installed the other containers, but sonarr refuses to load on my web browser.

In Portainer it shows running and running “docker ps” I see it started there too.

The config I used is straight from

docker create \ --name=sonarr \ -e PUID=1000 \ -e PGID=1000 \ -e TZ=America/New_York \ -p 8989:8989 \ -v /home/config:/config \ -v /home/media/tv:/tv \ -v /home/media/downloads:/downloads \ --restart unless-stopped \ linuxserver/sonarr

are uid and gid 1000 valid users? How are you trying to browse to the page? http://<ubuntu vm ip>:8989 is the right way

what does docker logs -f sonarr show? (pastehastebin please)

After your create, did you use docker run or docker start?

Thanks for the help.

Yes trying to access Sonarr via - :8989

Radarr works - :7878

Here is the pastebin

Radarr is using uid and gid 1000 as well (is sonarr and radarr ok to use the same?)

yep no problem with sharing users

i think you need to rebuild your container

2020-06-05T14:07:50.837155112Z no such table: Episodes
2020-06-05T14:07:51.036974347Z [Fatal] ConsoleApp: EPIC FAIL! ,
2020-06-05T14:07:51.036998308Z ,
2020-06-05T14:07:51.037005237Z [v2.0.0.5344] System.Exception: SQL logic error,
2020-06-05T14:07:51.037011986Z no such table: Episodes

looks like a cycle of crashing because the database is jacked.

Ok in portainer I removed the container completely.

I then went to the CLI and ran

docker create \
  --name=sonarr \
  -e PUID=1000 \
  -e PGID=1000 \
  -e TZ=America/New_York \
  -p 8989:8989 \
  -v /home/config:/config \
  -v /home/media/tv:/tv \
  -v /home/media/downloads:/downloads \
  --restart unless-stopped \

I then started the container in portainer… I still cant browse 8989.

Seems like a similar error?

ok, so a couple things i just noticed
you have /home/config:/config
are you also putting radarr’s config in this same path? you should be doing something like

that said, the corrupted database is already in config, so in addition to removing the container, you need to delete the sonarr stuff from /home/config so the database is new.

further, portainer breaks all the things, can you try doing your docker create and then from CLI just run docker start sonarr I only suggest portainer for viewing things, not for taking actions on your containers. I also suggest looking into compose, it will make your life easier.

1 Like

that was 100% the problem, the config folders were the same…

perhaps a hit in the documentation for Sonarr and Radarr to not do that?

it already is in the documentation.
also, each container’s config is specific to each container so /path/to/data for sonarr is path to sonarr data.

It can’t hurt to discuss internally making this more clear though, i guess.
glad you got it solved either way!

dont forget to mark the answer (if you’re able, tbh im not sure how discourse works) so others will know what fixed it for you.

Thank you very much for your time and help!