SWAG | avoid replying to any request?


How can I setup SWAG so it doesn’t reply with the default welcome message:

Welcome to your [SWAG] instance

A webserver and reverse proxy solution brought to you by
with php support and a built-in Certbot client.

We have an article on how to use swag here:

For help and support, please visit:

(links removed as I am newb)

I’d prefer… for security… that only the sites I actually config swag for sends a reply…


easiest way is to only create dns records for things you configure (ie, dont use dns wildcards)

outside of that, you can remove the site , show a 404, use allow/deny, a few options

thx. forgot my wildcard entry on cloudflare - was so focused on the SWAG setup.
removed everything except what I need and the A record…

@driz - just a quick followup. Do you know how I can deny access to the root domain.

so I’ve removed everything except for the 1 subdomain I want to expose.

but ‘domain . com’ still responds.

so www . domain . com doesn’t respond.
but domain . com still responds with the SWAG frontpage.

rules are set as follows:

default_policy: deny
- domain:

  - "sub . domain . com"
  policy: two_factor
- domain:
  - "domain . com"
  policy: deny

did you try any of the methods I listed? authelia isn’t our container, so i am providing tips that work in our container.