SWAG: change of DNS provider

I switched DNS provider for my domain and now I need to reset the certbot credentials in my SWAG container.

How can I do that?

I tried changing the docker-compose file with my new credentials. Didn’t work.
I then tried changing manually the file /etc/letsencrypt/cli.ini, but that didn’t work either.

SWAG keeps using my old DNS provider’s credentials. Then I removed the credentials in the dns-conf/old-dns.ini file, and of course, then SWAG couldn’t request a new certificate as there were no credentials. But it keeps pointing to that old-dns.ini file…

Thanks for your help.

please provide your docker run or compose and full container logs (they begin with our ascii logo)

Sorry, I just realized my error. My old DNS credentials didn’t need an email address.
Now I’m using Cloudflare and I added my email address in the docker-compose.yaml, and it worked. The logs shows that it detected a change:
Different validation parameters entered than what was used before. Revoking and deleting existing certificate, and an updated one will be created