Swag container no valid ip address (UnRaid)

Hi, after finally succeeding to get Swag running it has been working for a few months till my modem broke down and got a new one. Since I have the new modem I can’t get Swag back up running again even tho all the settings were the same.

Unraid docker container:

Ports are all open: 80, 180, 443, 1443.

Error Log:

What I tried to fix

  • recreated the whole container.
  • recreated all the port forwarding settings and made sure they were open.
  • Redid twice the video from spaceinvader.

I do know that I got a new public ip because i got a new modem, but in DuckDNS the ip has been updated to the latest ip. And I can ping the duckdns subdomain.

Hope someone can help, if you need more info or logs please ask :slight_smile:


Looks like your port forwarding is wrong. Outside port 80 ends up at the unraid gui, therefore validation fails.

You need to make sure that your outside port 80 ends up at swag’s port 80 inside the container.

See here: Troubleshooting Letsencrypt Image Port Mapping and Forwarding | LinuxServer.io

Thank you for your help, I recreated the port settings and don’t get error in the log file now!

But even now I can’t access the site I am trying to reach.

I posted all the settings over HERE hoping it will shed some light on the problem.

When I first setup duckdns and swag using the video from spaceinvader I had no problem, but even though I am using the same settings it just doesn’t want to work.

For testing purposes I am trying to access Overseerr as you can see in the pictures.

I can access your site here. Try on a cell phone with wifi turned off as described in that article I linked.

Your issue now is related to hairpin nat or nat loopback. Googling those terms should help you fix it either on your router, or by setting up a local dns (pihole or adguardhome would work)