SWAG gets stuck/freezes during startup

I have a VM where the SWAG setup was working fine before I moved the VM to a different DMZ. I verified checked that the container can reach the internet and can resolve DNS names. Also tried to see whats happening on the network and filtered everything out that I could account for, but seemingly no traffic from the SWAG instance.
In the container logs I see this (banner and local info removed):

using keys found in /config/keys 
Variables set: PUID=1000 PGID=100 TZ=redacted URL=redacted SUBDOMAINS=www,mail

nothing else, which is odd, as I should then see this:

Using Let's Encrypt as the cert provider SUBDOMAINS entered, processing

seems to me like the instance is stuck somewhere during startup (usually timeouts due to DNS or some IP filter rule).

also checked the logs in /config/log, in all logs looks like nothing is starting up (no errors logged though that could give a hint). all log lines are from earlier points in time when the container was running in the other environment.

any Ideas what would/should be happening there, where it is stuck? that could give me a hint what to look for to unblock the situation

how would I trace step by step through the startup procedure form the point I have shown above? (I think this is past s6 stage already) What script file would I need to look at?

Share the compose/run and full container logs

Thanks for coming forward. With a fresh view on the firewall rules I identified a rule that is causing the observed behavior. I will go from there and would ask again in this thread if I couldn’t solve it, so please dont close the thread, as I will do when I have solved it.

I was able to solve the problem, it had to do with IP filtering rules, nothing that could have been done on the layer of SWAG.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.