SWAG on QNAP Container Station port not working

I try to install SWAG on my QNAP NAS. I’m experimenting with the network settings. I can choose NAT or Bridge. With NAT the networking works, but every time the container is restarted it uses a different external portnumber. So it’s impossible to set the port forwarding on my router stable.

If I use Bridged as my networking it seems that the port 80 and 443 are not exposed. The port forwarding is set correctly. When I run the container I get these errors:
Challenge failed for domain <example.com>
http-01 challenge for <example.com>
Cleaning up challenges
Some challenges have failed.

I tried to create the container with the docker commandline, but I’m not able to set the netwerk Bridge setting.

So I’m a little stuck.

When inside the dockercontainer:
netstat -an
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0* LISTEN
udp 0 0*
Active UNIX domain sockets (servers and established)
Proto RefCnt Flags Type State I-Node Path

So it seems that SWAG is not listening to ports 80 and 443. Can I activate them manually?

Or is it possible to add 2 extra settings, for example: PORT_HTTP and PORT_HTTPS?

You need to use NAT networking and manually specify the port number you want to use when creating the container. Otherwise Container Station uses a random port for you.

Thank you it’s working

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.