Swag reverse proxy for Guacamole 1.4.0

Hey there, I’m trying to get reverse proxy for Guacamole to work, with little success. I’m running the latest release (1.4.0) via the offical docker image. First, I tried the subdomain.conf with my values filled in with little success, the only result is the following page:

Then I added what is suggested in the guacamole documentation for a nginx reverse proxy https://guacamole.apache.org/doc/gug/reverse-proxy.html#nginx

now I get an error nginx: [emerg] "proxy_http_version" directive is duplicate in /config/nginx/proxy-confs/guacamole.subdomain.conf:38

So then I comment the proxy_http_version out, but the result stays the same as in the image above.
This is my conf file:

server {
listen 443 ssl;
listen [::]:443 ssl;

server_name guac.*;

include /config/nginx/ssl.conf;

client_max_body_size 0;

    # enable for ldap auth (requires ldap-location.conf in the location block)
    #include /config/nginx/ldap-server.conf;

    # enable for Authelia (requires authelia-location.conf in the location block)
    #include /config/nginx/authelia-server.conf;

location /guacamole/ {
 # enable the next two lines for http auth
 #auth_basic "Restricted";
 #auth_basic_user_file /config/nginx/.htpasswd;

 # enable for ldap auth (requires ldap-server.conf in the server block)
 #include /config/nginx/ldap-location.conf;

 # enable for Authelia (requires authelia-server.conf in the server block)
 #include /config/nginx/authelia-location.conf;

include /config/nginx/proxy.conf;
include /config/nginx/resolver.conf;
set $upstream_app guacamole;
set $upstream_port 8080;
set $upstream_proto http;
proxy_pass $upstream_proto://$upstream_app:$upstream_port/guacamole/;

 #proxy_http_version 1.1;
proxy_buffering off;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection $http_connection;
access_log off;

What am I missing or doing wrong here?

I switched guacamole path with the WEBAPP_CONTEXT=ROOT in the docker compose for the guacamole container to / then the guacamole.subdomain.conf.sample works

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.