Swag Working with Certs, But Not Loading Domains

Swag is working but reverse proxy is not loading my domain.
Im using docker in unraid dashboard. It succesfully got the certs but im having a bit of difficulty understanding the nginx proxy conf. could someone tell me if this is correctly set it up for jellyfin

server {
listen 443 ssl;
listen [::]:443 ssl;

server_name stream.*;

include /config/nginx/ssl.conf;

client_max_body_size 0;

location / {
    include /config/nginx/proxy.conf;
    resolver 127.0.0.11 valid=30s;
    set $upstream_app 192.168.1.116;
    set $upstream_port 8096;
    set $upstream_proto http;
    proxy_pass $upstream_proto://$upstream_app:$upstream_port;

    proxy_set_header Range $http_range;
    proxy_set_header If-Range $http_if_range;
}

location ~ (/jellyfin)?/socket {
    include /config/nginx/proxy.conf;
    resolver 127.0.0.11 valid=30s;
    set $upstream_app 192.168.1.116;
    set $upstream_port 8096;
    set $upstream_proto http;
    proxy_pass $upstream_proto://$upstream_app:$upstream_port;

}

}

ive also setup my jellyfin install to port 443 on public port and portfowarded the ports 443 on my router. The network being used is the default docker bridge. Ive switche the unraid ports to 8008 for the dashboard. So 80 and 443 are only used by swag. Also i dont get what the second line in the config is for.

location ~ (/jellyfin)?/socket {
    include /config/nginx/proxy.conf;
    resolver 127.0.0.11 valid=30s;
    set $upstream_app 192.168.1.116;
    set $upstream_port 8096;
    set $upstream_proto http;
    proxy_pass $upstream_proto://$upstream_app:$upstream_port;

}

}

what is this do and why is it there?

ive also tried this config as well to no avail.

server {
listen 443 ssl;
listen [::]:443 ssl;

server_name stream.*;

include /config/nginx/ssl.conf;

client_max_body_size 0;

location / {
    include /config/nginx/proxy.conf;
    resolver 127.0.0.11 valid=30s;
    set $upstream_app jellyfin;
    set $upstream_port 8096;
    set $upstream_proto http;
    proxy_pass $upstream_proto://$upstream_app:$upstream_port;

    proxy_set_header Range $http_range;
    proxy_set_header If-Range $http_if_range;
}

location ~ (/jellyfin)?/socket {
    include /config/nginx/proxy.conf;
    resolver 127.0.0.11 valid=30s;
    set $upstream_app jellyfin;
    set $upstream_port 8096;
    set $upstream_proto http;
    proxy_pass $upstream_proto://$upstream_app:$upstream_port;

}

}

Post your jellyfin docker run

i used unraids built in docker UI through unraid community plugins. I never made a docker run i just use the Unraid UI to start it up. If theres a specific setting your looking for maybe i can help with that?

Edit the container settings, add a space somewhere, then delete it, hit save. It will show you the docker run

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name=‘jellyfin’ --net=‘bridge’ -e TZ=“America/Los_Angeles” -e HOST_OS=“Unraid” -e ‘NVIDIA_VISIBLE_DEVICES’=’’ -e ‘NVIDIA_DRIVER_CAPABILITIES’=‘all’ -p ‘8096:8096/tcp’ -p ‘8920:8920/tcp’ -p ‘1900:1900/udp’ -v ‘/mnt/user/Movies4You-Server/Jellyfin-Media/Movies/’:’/movies’:‘rw’ -v ‘/mnt/user/Movies4You-Server/Jellyfin-Media/TV-Show/’:’/tv’:‘rw’ -v ‘/mnt/user/Movies4You-Server/Jellyfin-Media/Music/Punk-Rock-Metal/’:’/music’:‘rw’ -v ‘’:’/cache’:‘rw’ -v ‘/mnt/user/appdata/jellyfin’:’/config’:‘rw’ ‘jellyfin/jellyfin’

afda68c60c5afd2eab9bebcfd758b26f3017d56fbcb6b18d1a47884dfdcffcde

I posted the docker up script above.

you realize that if he reads your message telling him you posted it, he will naturally see it… ie; no need to tell him. if you want quicker service, discord is it, patience (could be days) is required on all mediums though.

I’ve joined the discord. Where do I post in it. There’s no support tab that I saw?
EDIT: Nevermind disregard

good, i was about to make fun of you :stuck_out_tongue:

Are the containers in the same docker network?
I see Jellyfin on bridge.

Tip: I set swag and all web-open containers in a network called ‘web’.