Syncthing container - connection issues

I cannot get two syncthing containers’ devices to connect & sync successfully.

On syncthing’s dashboard I get “connection refused” at the remote device’s address of both devices, yet I can successfully SSH from either host to the other.

In the logs I get “Folder “Test” (hdfkq-hiikf) isn’t making sync progress - retrying in 16m0s.”

Under Actions > Settings > Connections only “Local Discovery is enabled” and adresses is specified “tcp://ipv4:22000”

The docker-compose via portainer is as follows:

image: linuxserver/syncthing
container_name: syncthing

network_mode: host

  - PUID=1000
  - PGID=1000
  - UMASK_SET=<022>
  - syncthing:/config
  - /data:/data
  - 8384:8384
  - 22000:22000
  - 21027:21027/udp
restart: unless-stopped

Even commenting out the ports and uncommenting “network_mode: host” doesn’t help to get the two devices to sync.

Any clues ? …

Can you please try deploying this using docker compose, see our sample here:

We do not support portainer as it causes a myriad of issues.

Definitely do not use network_mode: host


I was about to give up on syncthing …

… and then by disabling “TX Checksum Offloading” at the virtual network interface that was timing out, syncthing came to life !

However, this was with “network_mode: host” set. With “network_mode: host” not used, what do you specify under Adresses within the Advanced settings of the Remote Host ?

With “NAT Traversal” also enabled under the SyncThing host’s Settings > Connections I cannot get the devices to connect once I have “network_mode: host” removed.