Trouble with permissions in transmission but not in others

hello there,
I’m building a new server and i want to do all the things in docker containers. i’m fairly new at this. Previously i ran a few stacks but Tranmsission was on the host (and worked)

I’m using the
i have edited my docker compose like this:

version: "2.1"
    container_name: transmission
      - PUID=1002
      - PGID=100
      - TZ=Australia/Sydney
      - USER=*********** #optional
      - PASS=************* #optional
      - /config/transmission:/config
      - /DATA/Dropzone/Finished:/DATA/Dropzone/Finished
      - /DATA/Dropzone/Watch:/DATA/Dropzone/Watch
      - /DATA/Dropzone/Incomplete:/DATA/Dropzone/Incomplete
      - 9091:9091
      - *******:*******
      - *******:*******/udp
    restart: unless-stopped

the container builds and runs and i can get to the web gui from another machine. But the watch folder doesn’t add and any torrent i add immediately errors with
Error: Permission denied (/Data/Dropzone/Finished/name of torrent
this error appear in the gui.
if i go into portainer, the log has this to say

[2022-06-01 03:01:40.828] nameoftorrent.m4a tr_fdFileCheckout failed for "/Data/Dropzone/Incomplete/Archive on 4 - Over the Top (2022-05-27).m4a.part": Permission denied (/home/buildozer/aports/community/transmission/src/transmission-3.00/libtransmission/inout.c:95)
[2022-06-01 03:01:40.828] Error while flushing completed pieces from cache (/home/buildozer/aports/community/transmission/src/transmission-3.00/libtransmission/session.c:571)
[2022-06-01 03:07:40.828] Couldn't create "/Data": Permission denied (/home/buildozer/aports/community/transmission/src/transmission-3.00/libtransmission/file-posix.c:243)
[2022-06-01 03:07:40.828] Couldn't create "/Data/Dropzone/Incomplete": Permission denied (/home/buildozer/aports/community/transmission/src/transmission-3.00/libtransmission/fdlimit.c:174)
[2022-06-01 03:07:40.828] nameoftorrent.m4a tr_fdFileCheckout failed for "/Data/Dropzone/Incomplete/nameoftorrent.m4a.part": Permission denied (/home/buildozer/aports/community/transmission/src/transmission-3.00/libtransmission/inout.c:95)
[2022-06-01 03:07:40.828] Error while flushing completed pieces from cache (/home/buildozer/aports/community/transmission/src/transmission-3.00/libtransmission/session.c:571)
[2022-06-01 03:13:40.827] Couldn't create "/Data": Permission denied (/home/buildozer/aports/community/transmission/src/transmission-3.00/libtransmission/file-posix.c:243)
[2022-06-01 03:13:40.827] Couldn't create "/Data/Dropzone/Incomplete": Permission denied (/home/buildozer/aports/community/transmission/src/transmission-3.00/libtransmission/fdlimit.c:174)

and so on.
i’m running two other containers that use the same volumes all with puid=1002 and pgid=100 and they don’t have any issues. on the host ls -la of the data/dropzone folder gives

drwxrwxrwx  14 media users  4096 May 30 12:27 Finished
drwxrwxrwx+  2 root  users 12288 May 30 12:26 Incomplete
drwxrwxrwx+  3 root  users  4096 Jan 10  2014 received
drwxrwxrwx+  2 media  1000  4096 Jun 29  2019 sftp
drwxrwxrwx+  4 media  1000  4096 Jan  9  2021 .Trash-1000
drwxrwxrwx+  2 root  users 36864 May 31 18:22 Watch

so i’m not sure what’s going on, or how to fix it. Not sure if you need other info.
hope you can help

I’ll start with the normal we do not support or recommend portainer for deployment of containers. It introduces a multitude of issues.

that said, we know you have permissions issues from the error I see nothing owned by group 100 and half the folders are owned by root which is not uid 1002.

what kind of mount is /DATA? is it a local mount, remote mount, usb mount?

Hi Driz, thanks for the help.
understood about the support, i will do my best not to be a help-vampire. Feel free to advise another forum if I take too many spoons.

/DATA is a symlink to a local path on the host (spinning rust sata as sda; my os is sdb) at
i’m running a lsio/sabnzd and lsio/sonarr container with same id and they can create move and delete files within those volumes. I agree that it is a permissions issue but i don’t understand why if the others work.
When i built the server before the docker install i created a user called appuser and added it to the users group.

 id appuser
uid=1002(appuser) gid=100(users) groups=100(users),992(docker)

which is what i’ve been using in the docker compose.
hmmm i don’t think root should be the owner of the incomplete and watch folder. I created three users

cat /etc/passwd (abridged)

with media being the owner of my media, homeass being for homeassistant which i know is going to be a pain so gave it it’s own user. and appuser which is for docker containers to run under.

i used the command

chown media Watch
chown media Incomplete

then to confirm

ls -l (abridged)

then started the transmisison container
same error

[2022-06-02 07:58:49.460] Couldn't create "/Data": Permission denied (/home/buildozer/aports/community/transmission/src/transmission-3.00/libtransmission/file-posix.c:243)
[2022-06-02 07:58:49.460] **Couldn't create "/Data/Dropzone/Incomplete": Permission denied (/home/buildozer/aports/community/transmission/src/transmission-3.00/libtransmission/fdlimit.c:174)**
[2022-06-02 07:58:49.460] mytorrent.m4a tr_fdFileCheckout failed for "/Data/Dropzone/Incomplete/mytorrent.m4a.part": Permission denied (/home/buildozer/aports/community/transmission/src/transmission-3.00/libtransmission/inout.c:95)
[2022-06-02 07:58:49.460] Saved "/config/resume/45cbebcf2c36e889e3e88cf0bd7a8d597ce56cc1.resume" (/home/buildozer/aports/community/transmission/src/transmission-3.00/libtransmission/variant.c:1221)

interestingly is this line in bold
Couldn’t create “/Data/Dropzone/Incomplete”: Permission denied (/home/buildozer/aports/community/transmission/src/transmission-3.00/libtransmission/fdlimit.c:174)

why is it trying to create this folder if it already exists? Is it related to this bug

Default directories are re-created unnecessarily #200


it was because my folders were set as /Data/Dropzone…
and not /DATA/Dropzone…

just. ugh.
that was like three nights of troubleshooting.

i couldn’t work out why it was trying to create those folders when they already existed.
it was because they didn’t.

thanks for you help. The Watch folder isn’t working still but that’s a different fight :0)

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.