TVheadend with host mode in a swarm

Hello, everybody,

I put on a Docker Swarm and try now for meanwhile 3 nights tvheadend with host network to bring to run because I want to integrate my Digibit R1 there.

Now I am with my Latin at the end and therefore turn to you…

Of course I have tested different confis… here times 2 options… of course not at the same time :wink:

version: '3.4'

volumes:
...

networks:
#Option 1
  multimedia:
    ipam:
      driver: default
      config:
        - subnet: 192.168.1.0/24
        - gateway: 192.168.1.1
#Option 2
  hostnet:
    external:
      name: host

services:
  tvheadend:
    hostname: Docker_tvheadend
    image: linuxserver/tvheadend
    deploy:
      mode: replicated
      replicas: 1
      restart_policy:
        condition: any
       delay: 5s
        max_attempts: 3
        window: 120s
    environment:
...
    volumes:
...
    networks:
#Option 1
      multimedia:
        ipv4_address: 192.168.1.114
#Option 2
       hostnet:
#    network_mode: host
    ports:
      - 9981:9981
      - 9982:9982
      - 554:9983
      - 1900:1900/udp
      - 8875:8875

Unfortunately our container’s aren’t built with Docker Swarm in mind nor are they tested on Swarm.

Though I can confirm that our TVHeadend image works great with a Digibit R1.

Too bad, but I still want to try to get your container to run in my swarm and it does… but unfortunately not with network_mode: host

That sounds good already…

Maybe someone still has a hint or a solution for my problem.