Unifi Controller only works with AP

Im trying to run Unifi Controller on docker but it seems to not work this is how i use it

docker run --restart always --name unifi -p 8080:8080 -p 8443:8443 -p 3478:3478/udp -p 10001:10001 -p 6789:6789 -p 5656-5699:5656-5699/udp -p 1900:1900/udp -p 27117:27117 -e PUID=1001 -e PGID=1001 -e variable=TZ -e value=Europe/Stockholm -v /home/containers/unifi:/config linuxserver/unifi

The AP connects but neither the Switch or the USG wants to work and im not sure why when i install the Controller Software on a my home pc which is Windows i see the USG and Switch Automatically.

I believe if you have already adopted the devices with an existing install, you need to ssh into each device and re-adopt them. There are notes in the readme about adopting a AP, I suspect it’ll be the same for a USG

1 Like

I have done what they specify here:

ssh ubnt@$AP-IP
set-inform http://$address:8080/inform

But for the FW and SW but this seems to have little effect.

you should manually tell your controller its ip so you don’t have to set inform manually for each device:
Go to the controller settings tab then make sure you have the address of your controller and the checkbox that says Override inform host with controller hostname/IP checked
Like the picture below:

and also make sure it is the same ip as the old controller which you have restored the backup from or that you have reset the devices that were connected to the old controller