Unraid, Portainer, and LSIO Nextcloud image

Hi all,

I am using the LSIO in a stack (essentially a docker-compose file) in portainer to create my nextcloud instance. My unraid box is the portainer server and I have another box running as a portainer-agent. I am using the nextcloud LSIO image on the portainer-agent instance and have successfully mounted SMB shares as volumes to that container. The container launches and runs successfully but I get an error that the config file is read only. The UID and GID match the user on the unraid NAS that has read/write permissions to the SMB share that’s mounted. Subfolders are all created and present. I have tried a lot of various permission sets over the last few days and would love some assistance.


version: "2.1"
    image: lscr.io/linuxserver/nextcloud
    container_name: nextcloud
      - '444:443'
      - PUID=1003
      - PGID=100
      - TZ=America/Chicago
      - nextcloud_config:/config
      - nextcloud_data:/data
    restart: unless-stopped

    image: lscr.io/linuxserver/mariadb
    container_name: nextcloud_mariadb
      - '3306:3306'
      - PUID=1000
      - PGID=1000
      - MYSQL_DATABASE=nextcloud
      - MYSQL_DATABASE_USER=nextcloud
      - TZ=America/Chicago
      - /etc/nextcloud_mariadb:/config
    restart: unless-stopped
      type: cifs
      o: "username=greenhouse,password=,rw,nobrl"
      device: "//10.10.0.xxx/appdata/nextcloud"
      type: cifs
      o: "username=greenhouse,password=,rw,nobrl"
      device: "//10.10.0.xxx/nextcloud"

Nextcloud log:

Cannot write into "config" directory!

This can usually be fixed by giving the web server write access to the config directory.

But, if you prefer to keep config.php file read only, set the option "config_is_read_only" to true in it.

See https://docs.nextcloud.com/server/28/go.php?to=admin-config

We do not offer any support for remote mounts. However, you are welcome to seek best-effort help in #other-support on our discord.
just to toss this out, while we DO support unraid (we make templates for it) we do NOT support using portainer to deploy any of our containers.

Thanks driz. Any additional info out there on why y’all don’t support using portainer at the moment?

Just following up here that I opted to instead use the official AIO image and I have not tried testing the below on the LSIO image.

I made the switch to the AIO image and mounted the remote shares via fstab on the host machine, mapping them to the appropriate places in the docker container and I’ve got things up and running now. I may go back and try the LSIO image with the mounts to see if that would have worked and if I do I’ll come back and follow up here.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.