Upgrade bazarr - module not found error, using docker-compose/OpenMediaVault

I was running linuxserver/bazarr:1.3.1 and did an image update on the same version. And sine then get the following

Bazarr starting…

Bazarr exited.

Traceback (most recent call last):

File “/app/bazarr/bin/bazarr/main.py”, line 22, in

from app.check_update import apply_update, check_releases, check_if_new_update  # noqa E402


File “/app/bazarr/bin/bazarr/app/check_update.py”, line 15, in

from .config import settings

File “/app/bazarr/bin/bazarr/app/config.py”, line 8, in

from subliminal.cache import region

File “/app/bazarr/bin/bazarr/…/libs/subliminal/init.py”, line 12, in

from .core import (AsyncProviderPool, ProviderPool, check_video, download_best_subtitles, download_subtitles,

File “/app/bazarr/bin/bazarr/…/libs/subliminal/core.py”, line 29, in

from babelfish import Language, LanguageReverseError

File “/app/bazarr/bin/bazarr/…/libs/babelfish/init.py”, line 14, in

from .converters import (LanguageConverter, LanguageReverseConverter, LanguageEquivalenceConverter, CountryConverter,

File “/app/bazarr/bin/bazarr/…/libs/babelfish/converters/init.py”, line 5, in

from pkg_resources import iter_entry_points, EntryPoint

ModuleNotFoundError: No module named ‘pkg_resources’

I am using OMV (OpenMediaVault) that uses docker-compose. I have removed the image, did a pull and recreate via the OMV/Compose plugin and fails. I have tried again (after deleting the image) on the command line with compose and have the same problem.

Something similar happened with calibre-web a month ago where I ended up porting the compose file to a command line run and got it working that way. Not sure why compose didn’t work. This solution wouldn’t be scalable with the many containers I am running.

I have seen the linuxserver.io page about Synology and Portainer, but this is via compose and OMV. I do run Portainer but the container is not created and managed in portainer (as mentioned i have deleted the image before manually running).

are you using compose from some OMV UI or did you create a compose yaml and you are running docker compose up -d from the cli? We do not support the use of ANY ui (except unraid) because they cause so many issues with inconsistent translation of yaml.

That said, please provide the compose and full container logs (starting with our ascii logo)

I deleted the image, removed the container and even restarted the server manually. Then ran through the steps again hoping to capture everything you needed including the logs.

Not sure what was different now, but tried multiple times and it seems to work fine now.
When I posted on OMV forum, they say the plugin simple runs the docker compose commands without additions.

Either way, something changed on my side, and it seems to work. Apologies for false alarm.

everyone says this, it’s always been a lie born from misunderstanding. it’s not magic, they have to interpret their UI and translate that into what they think you mean for compose. We do not and will not support anything other than docker run or docker compose (via yaml and a cli command).

that said, im glad you got it sorted out, have fun!