Upgrading Nextcloud

Hi

First thanks for your efforts on making docker effortless! :slight_smile:
Yet I do have a problem with updating to the latest version. Everything I do results in the same version of nextcloud running (–> the one on the first install --> 15.0.2).

What I already tried:

  • docker-compose up -d
    –> no update (new pull) at all - for any image
  • docker-compose down --rmi all -v
    docker-compose up -d
    –> new pull of all images, even giving me a “Downloaded newer image” as a confirmation that a newer version has been downloaded.
  • docker-compose stop nextcloud
    docker image rm nextcloud
    docker container rm nextcloud
    docker-compose pull nextcloud
    docker-compose start nextcloud
  • Everything except the - -build-option in this thread.

Not a single approach worked. I always have my “good old version 15.0.2”.

Any ideas/helpThis text will be hidden would be very much appreciated.

PS: The linuxserver/plex - image had no problem updating after stopping all services with docker-compose down and restarting with docker-compose up -d

Nextcloud is one of our containers you need to update from within the webui. Just make sure you’re running the latest image before you do this.

Wow, that was fast!!! Thanks - doing it now! :smiley:

ohoh…

I encountered this problem (I hit the wrong button…)

Tried to fix it by applying the recommended command. I got:

The posix extensions are required - see http://php.net/manual/en/book.posix.php
PHP Warning: fileperms(): stat failed for /data/nextcloud.log in /var/hda/files /nextcloud/config/www/nextcloud/lib/private/Log/File.php on line 140
{“reqId”:“XyGHarvTZdljgvUzC7nd”,“level”:3,“time”:“2019-06-09T21:03:14+00:00”,“re moteAddr”:"",“user”:"–",“app”:“PHP”,“method”:"",“url”:"–",“message”:“fileperms (): stat failed for /data/nextcloud.log at /var/hda/files/nextcloud/confi g/www/nextcloud/lib/private/Log/File.php#140”,“userAgent”:"–",“version”:" 15.0.2.0"}
{“reqId”:“XyGHarvTZdljgvUzC7nd”,“level”:3,“time”:“2019-06-09T21:03:14+00:00”,“re moteAddr”:"",“user”:"–",“app”:“PHP”,“method”:"",“url”:"–",“message”:“You are u sing a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/hda/files/nextcloud/config/www/nex tcloud/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18”,“u serAgent”:"–",“version”:“15.0.2.0”}

Before I break anything (more) - do you have a suggestion how to go forward (except installing/enabling posix and trying again)?

Thanks

Answer:
https://docs.nextcloud.com/server/9/admin_manual/maintenance/enable_maintenance.html