Webgrabplus cron issue

Hello fellow dockerers (is that even a word? :laughing:)

Im a happy linuxserver docker user, got all my services up and running (around 15), now I face a last challenge with webgrabplus container.

My cron does not execute unless I do it manually.
I did check logs. Nothings pops up.
I did check and made sure I have a new empy line in my cron.
I tried different hours and configurations with cron, nothing works.
No errors but no execution either.

14 22 * * * s6-setuidgid abc /bin/bash /defaults/update.sh

I do however see in the manually executed log my last line reads like this

[ Debug ] statistics upload error: The remote server returned an error: (404) Not Found.

But the file is correctly generated and placed in the needed folder.
Any advice? Thank you!

LE: Could it be a permission error somehow? See below, “defaults” folder owner is “abc” but the files within are owned by root? Or is this normal as it is?

You can try to change owner/group to abc:abc and permissions to +x on the update file and see if that helps.

I don’t know what statistics is being uploaded. Might be something new wg++ started doing.

The error with statistics upload is not affecting any functionality it seems. Found an answer on their forums.

The upload of some statistics to the webgrabplus server was introduced in an update of V1 (see http://www.webgrabplus.com/download/sw/v111/upgrade/53). You can append a # to the mode in WebGrab++.config.xml to disable the (attempted) upload, e.g. <mode>n#</mode> .

The problem still persists, the folders permissions are correct (webgrab uses s6-setuidgid to drop root rights for those folders/files when executing the command), so I am still in the dark as why my cron won’t work…

LE: Since I found no way to have the wg-cron executing, I setup a cron on the host. I do not know how good my solution is, but until I find the culprit, I’ll use this. Is it safe?

docker exec -it webgrabplus /bin/bash -c "s6-setuidgid abc /bin/bash /defaults/update.sh"

LE2: I think there may be a bug with the container… Even on the host, cron does not execute. I mean it executes, but nothing is changed/output. Normal command ran from the terminal works. As soon as it’s setup with cron, nothing happens. Permissions are ok, cron is ok.
I also tried cron with script like

1 * * * * root /sharedfolders/docker/webgrab.sh

#!/bin/sh
# Update Webgrabplus docker container EPG data
docker exec -it webgrabplus /bin/bash -c "s6-setuidgid abc /bin/bash /defaults/update.sh"

Nothing happens still. This is on host. And I have no log.
Next attempt is to try on docker, then on host something like this, to see if I get any output.

2 * * * * s6-setuidgid abc /bin/bash /defaults/update.sh >> /config/cronlog 2>&1

This drives me crazy :slight_smile:
Thanks for your input.

LE3: Found the bug. As soon as I edited the wg-cron file to modify the cron times, the cron dropped the owner execute rights. I do not know what cause this, but the solution is to re-apply the execute rights after modifying the file. I do not know if this bug is only particular to my setup, I plan to report the bug on github in order for the team to test.

Case solved!

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.