Webtop work on LAN but not after reverse proxy

Hi, i have a functional Webtop docker, which work ok on LAN.
Also in LAN i have multiple http/https services reachable from public internet with Nginx Proxy Manager.

I’m pretty sure the config on NPM is ok due the website open, favicon load, and black circle load aswell. But nothing else.

From internet if i do VPN i can see it propely (at the end the VPN get me on my LAN) so the problem is not at the remote viewer device.

Webtop runs under RPi 4. Any idea?

We don’t offer any support for NPM. It would be best to seek help from the devs/support of NPM if any exists.

Thanks but is not a NPM config issue, i have 20+ Proxy Hosts and this is the sole that do not load correctly from outside LAN.

As commented on LAN is ok, but over WAN only favicon and dark circle load, the rest of assets at Desktop do not display

Please provide the compose or run snippet for webtop and full container logs (they begin with our ascii logo)

If nothing stands out in the logs/compose, then for testing, you can port forward 3000 from your router to your docker host and show the dev console output when connecting from the WAN to your webtop instance. To accomplish this, i would suggest limited the source ip to that of your mobile phone when not on wifi, though whatever you feel safe doing is fine.

I found a clue on what the problem may be. On LAN i access webtop via IP, on WAN i was accesing via domain name. If over WAN i use my public ip address instead of domain name, Webtop load OK.

I’ll try modify hosts file for Webtop to know this domain name is himself. Thanks for support!

I was looking into this issue as well, since I have discovered that I can access the VNC inside the docker container using IP address or hostname and port inside my LAN, but trying to access it via the NGINX reverse proxy using the URL only does not work (I can access the correct webtop page but it cannot connect to the VNC service).
After playing around with my nginx config, I found this page that directed me to the right information and config, specifically from Upstream Declaration and Virtual Host Configuration. Everything works now. I believe it has to do with requiring access to websockets and not getting any. If this isn’t your issue, I apologize for taking up space, but I hope this helps other people with this issue.

Hello sergioalegre

In Nginx Proxy Manager, on the Details tab, the following settings:

  • Cached Assets
  • WebSockets Support
  • Block Common Exploits
    Additionally Please consider password protecting the app with an Access Control List.
    After completing the above I was able to access WebTop offsite via DNS name.