Grocy only works if not using "volume"

Hi everybody,

below is my docker-compose.yaml I use for grocy. This version works… however, previously I had tried to mount the /config folder, which would always result in the service starting, but when I opened the URL I’d get some error I can currently not reproduce, but it looked like something was wrong with the web server, as there was no grocy login page or anything like that, just a plain error page.

I’d like to have all relevant data in a volume so that I don’t have to start over if I need to re-install/move to another machine/etc.; is there something I need to consider when mounting a volume?

I thought of using docker cp grocy:/config <dir>/config via cron, but if there is a way to just mount that volume, I’d prefer that.

Or is there another path other than /config that I’d need to save?

I just checked to make sure I hard the correct PUID/PGID - and I do.

Thank you in advance for your ideas :slight_smile:

version: "2.1"
    container_name: grocy
      - PUID=1000
      - PGID=1000
      - TZ=Europe/Berlin
    # volumes:
    #   - ./config:/config
      - 9283:80
    restart: unless-stopped

sounds like there is an issue with the folder you’re trying to mount. First of all, you really should use an absolute path for the path rather than a relative one, and make sure that it is dedicated to this container and not shared with any others

1 Like

Thank you!

This worked:

  • copy /config from existing grocy
  • recreate docker-compose.yaml (using a different folder, but still using the relative path, just to see whether that was what caused the issue, but it still worked)
  • deleting grocy container
  • recreating it via docker-compose up -d

Awesome :slight_smile:

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.