Grocy: Unable to connect when opening URL


I am trying to use Grocy with the the linuxserver docker image. It is the first time for me to use Docker. I have carefully read the general chapters of the linuxserver documentation and tried to start the Grocy image on a Raspberry Pi 2 with a fresh Raspbian.

The setup of the container using docker-compose works very well, the container is created and started. I can see it is running by typing docker ps. However, when I open (the pi’s IP address), the browser shows an error. It is unable to connect and show the login page. I am connected to the Pi using ssh and I am trying to connect to the login page on my PC on the same local network.

I have tried many times. I followed the instructions from this question: I don’t know where to look next. I haven’t found anyone with the same issue, everything seems to run with no issue normally.

I would apreciate it if somone could point me to the right direction.
Thank you.

My docker-compose.yaml below:

version: "2.1"
    container_name: grocy
      - PUID=1000
      - PGID=1000
      - TZ=Europe/Paris
      - /home/pi/grocy:/config
      - 9283:80
    restart: unless-stopped