PLEX server on Raspberry pi 4

Hi to everyones,
I’d like to build small home linux server with a raspberry pi4,
I had installed ubuntu server and i’d like to use docker to mount container with all i need.
I choose linuxserver/plex because official one cannot works for ARM systems.
This is the configuration of official image i use in my computer and it works fine, i can reach plex server on plexserver.lan. i’d like configure linuxserver/plex in same way, but i can reach plex frontend but it cannot connect to plex server.

image: plexinc/pms-docker
container_name: plex
hostname: plexserver
- VIRTUAL_HOST=plexserver.lan
- TZ=Europe/Rome
- PLEX_CLAIM=<my_claim>
- ADVERTISE_IP=,https://plexserver.lan/
- ALLOWED_NETWORKS=,, # allows communicate to plex server without authentication over pi network
- $PWD/plex/data:/data
- $PWD/plex/temp:/transcode
- $PWD/plex/config:/config
restart: unless-stopped
- 32400/tcp
- 3005/tcp
- 8324/tcp
- 32469/tcp
- 1900/udp
- 32410/udp
- 32412/udp
- 32413/udp
- 32414/udp
- “plexserver.lan:$HOST_IP”
- pi

You think it might be helpful to tell us how you’re configuring our container and perhaps include some logs?

Also, that’s not our container you’re using.

@j0nnymoe He did say it was

Maybe this could help.

Yes, i’m sorry but as start point i pick up official image! :hugs:
I’ll put my configuration soon. I have not problems with host network and your image (configuration suggested) but i’m trying to put all my containers behind nginx that helps me to route throw them.

I posted official image configuration because it works, i reached plex at plexserver.lan, but that image is not ARM compatible so i need to replace it.

For official image the magic happens in ADVERTISE_IP but here i cannot configure it.

plex webpage -> settings -> network -> custom server access url
just put,https://plexserver.lan/ in there
We do not currently have that as an environment variable in our plex image.

The allowed networks stuff goes in the same spot but in list of ip addresses and networks that are allowed without auth